xf86-input-mouse-1.2.2, mouse DEceleration problem

Giuliano Pochini pochini at shiny.it
Mon Oct 22 15:03:02 PDT 2007

On Mon, 22 Oct 2007 19:18:51 +0200
Matthias Hopf <mhopf at suse.de> wrote:

> On Oct 21, 07 22:38:41 +0200, Giuliano Pochini wrote:
> > With xf86-input-mouse-1.1.1 I put "xset m 1/2 1" in my .xinitrc file to
> > halve mouse speed. The same command on v1.2.2 doens't work fine anymore:
> > fast movements are ok, but when I move the mouse slowly the mouse pointer
> > doesn't move. Interestingly, xev still reports all MotionNotify events even
> > if the coordinates of the pointer don't change.
> Are you sure that this only happens with this mouse driver? It sounds
> like something else in you updated has changed. Also note that 1.1.1 is
> quite outdated (> 1 year ago), in the meantime we have mouse-1.2.3

I updated the whole X and I'm having a lot of problems :(. I also tried to
compile 1.1.1 but it fails due to ABI changes.

> You might want to take a look at Option "Sensitivity" in mouse.4 manpage
> of mouse-1.2.2 and up.

That man page doesn't say anything about xorg.conf options. Anyway, I tried
sensitivity 5 and "xset m 1/10 1": it behaves exactly like I wrote above.
Sensitivity 0.5 and "xset m 1 1" halves mouse speed without drawbacks.


More information about the xorg mailing list