Does the Evtouch driver support the usb Elo 2216 resistive touch screen?

Nate Moseman natemoseman at
Fri Oct 26 22:30:38 PDT 2007

I've been banging my head against this one for a while now, but I can't
figure out what I am suppose to be doing.

I am using Debian Lenny/Sid with their Xorg packages. I've tried the
Elographics driver, but my thing is not serial; it's usb so I figured that
it's not suppose to be used with my device. I've tried hacking a 'elousb'
driver and was able to get it to compile and sorta get loaded in this
release... but I have absolutely know clue what I am doing. I can get the
module to load but in it still complains that the driver is non-existant.

I got it from:

So I figured the evtouch seems to be the right driver.. but people only talk
about Elo Intellitouch devices work which are accuostic devices, mine is a
accutouch and is resistive so I figure it's different and I don't know if
it's supported. I can get it to respond to key presses and I can sometimes
get the cursor to wiggle back and forth at the bottom of the screen or the
top of the screen and once sort a middle of the screen.
But I can't get it to move up and down any.

When trying to run the calibration tool it'll respond to clicks, but it
doesn't seem to know that the cursor is moving around any. The minimal stays
at '0' and the maximum stays at '2000' always for both X and Y no matter how
much I move things around.

The udev rules are a bit odd. It shows up as a joystick device? (is there a
kernel bug here?)
ls -l /dev/input/by-id/
total 0
lrwxrwxrwx 1 root root 9 Oct 25 09:19
-> ../event0
lrwxrwxrwx 1 root root 6 Oct 25 09:19
-> ../js0

This is what I get from lsusb -v:
Bus 002 Device 002: ID 04e7:0050 Elo TouchSystems
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               1.10
  bDeviceClass            0 (Defined at Interface level)
  bDeviceSubClass         0
  bDeviceProtocol         0
  bMaxPacketSize0         8
  idVendor           0x04e7 Elo TouchSystems
  idProduct          0x0050
  bcdDevice            1.00
  iManufacturer           1 EloTouchSystems,Inc
  iProduct                2 Elo TouchSystems 2216 AccuTouch<AE> USB
Touchmonitor Interface
  iSerial                 3 50U00000
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength           34
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          4 Model 2216
    bmAttributes         0xe0
      Self Powered
      Remote Wakeup
    MaxPower                0mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           1
      bInterfaceClass         3 Human Interface Devices
      bInterfaceSubClass      0 No Subclass
      bInterfaceProtocol      0 None
      iInterface              5 SmartSet Protocol
        HID Device Descriptor:
          bLength                 9
          bDescriptorType        33
          bcdHID               1.00
          bCountryCode           33 US
          bNumDescriptors         1
          bDescriptorType        34 Report
          wDescriptorLength     126
         Report Descriptors:
           ** UNAVAILABLE **
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0008  1x 8 bytes
        bInterval               5
Device Status:     0x0000
  (Bus Powered)

For the Xorg.conf I tried similar configurations to this one:
Section "InputDevice"
    Identifier "touchscreen"
    Driver "evtouch"
    Option "Device"

    Option "DeviceName" "touchscreen"
#    Option "MinX" "98"
#    Option "MinY" "43"
#    Option "MaxX" "940"
#    Option "MaxY" "925"
   # Option "ReportingMode" "Raw"
    Option "Emulate3Buttons"
    Option "Emulate3Timeout" "50"
    Option "SendCoreEvents" "On"
#Option "SwapX" "1"
#Option "SwapY" "1"
#    Option "Calibrate" "1"

And I did add a dummy device..

Section "InputDevice"
    Identifier "dummy"
    Driver "void"
    Option "Device" "/dev/input/mice"

I realy want to get this working. Anything that I can do to help.. I'll work
for it. I'll dissassemble the device and attack it with a multimeter if need
be, but my experiance at this sort of thing is very very slight.

Thank you.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the xorg mailing list