Need help solving Xorg slowness.

Ray Van Dolson rayvd at
Wed Oct 31 09:58:46 PDT 2007

Hi all, I've been living with slowness / sluggishness on my system for
a long time now.  Always have attributed it to lousy Radeon drivers
though, and thought I might see some better performance from the brand
new fglrx drivers that just came out.  Alas, I did not and so I thought
it was at least worth a try tracking this down before I either chuck
the card for an NVidia or revert to Windows. :)

The card itself is an ATI Radeon 9800XT (ASUS rebranded) -- I believe
this is using an r350 chip?  In any case, while a bit dated it still
should be plenty fast for 2D, but within Xorg it feels at times like
I'm using the vesa driver (I'm not btw :).  I've tried using both the
open source 'radeon' driver as well as the fglrx driver in various

I'm running on Fedora 7 currently with Xorg v1.3.0 + whatever patches
Fedora applies.  Kernel is  lspci output for my video card:

01:00.0 VGA compatible controller: ATI Technologies Inc RV350 NJ [Radeon 9800 XT] (prog-if 00 [VGA])
        Subsystem: ASUSTeK Computer Inc. Unknown device c000
        Flags: bus master, stepping, 66MHz, medium devsel, latency 255, IRQ 17
        Memory at e8000000 (32-bit, prefetchable) [size=128M]
        I/O ports at d800 [size=256]
        Memory at d7000000 (32-bit, non-prefetchable) [size=64K]
        Expansion ROM at e7fe0000 [disabled] [size=128K]
        Capabilities: [58] AGP version 2.0
        Capabilities: [50] Power Management version 2

This is on an AMD T-Bird 2100+ (1.3GHz?) with a GB of RAM.  ASUS A7V333

Symptoms are that resizing windows and anything "redrawing" really is
laggy.  A lot like when you are running the vesa driver althought not
quite that bad perhaps.  Firefox in particular when switching between
tabs takes noticeably longer than it does on my NVidia-based system at
work.  It just "feels" sluggish.

My current config and X logs are here:

Currently am using fglrx as you can see, but can switch to radeon for
testing if necessary.  Performance doesn't change much between the two.

I've also run oprofile on the system, and noted the following (this
during a lot of window resizing and Firefox tab switching and

# opreport 
CPU: Athlon, speed 1300.17 MHz (estimated)
Counted CPU_CLK_UNHALTED events (Cycles outside of halt state) with a unit mask of 0x00 (No unit mask) count 100000
  samples|      %|
    28251 33.6017
    20255 24.0913 no-vmlinux
     6029  7.1709 Xorg
          samples|      %|
             5999 99.5024 Xorg
               30  0.4976 anon (tgid:3414 range:0x110000-0x111000)

# opreport -l
CPU: Athlon, speed 1300.17 MHz (estimated)
Counted CPU_CLK_UNHALTED events (Cycles outside of halt state) with a unit mask of 0x00 (No unit mask) count 100000
samples  %        image name               app name                 symbol name
20255    24.0913  no-vmlinux               no-vmlinux               (no symbols)
15714    18.6902                        fbCopyAreammx
4751      5.6508                        fbSolidFillmmx
4732      5.6282                        fbCompositeSolidMask_nx8x8888mmx

Full results here:

>From a quick Google, it appears that some of these calls (fbCopyAreammx
in particular) are non-accelerated fallback functions.  Could this be
the source of my problem?

I am using XAA vs EXA (XAA is default) as EXA didn't appear to help
much or didn't work right last time I tried.  Can try again.

What else can I do to track this issue down?  Happy to open a bug here
and provide whatever help / testing is necessary.

Any thoughts?  I _know_ this card has the horsepower to be much faster
(it is very very fast still in Windows).

Thanks in advance!

More information about the xorg mailing list