Virtual desktop doesn't work anymore

Manuel Ravasio manuelravasio at
Sun Sep 16 04:15:28 PDT 2007

Hello all.

I've been using virtual desktop since 1999, adding a suitable "Virtual" line in Screen section of xorg.conf (in the past it used to have another name, which I can't remember right now). My Dell laptop has a 1024x768 monitor and I use a 1600x1200 or 2048x1536 virtual desktop.

Recently I updated from Slackware 11.0, running X11R6.9.0, to Slackware 12.0, running "X Window System Version 1.3.0" (from "X -version" output) and virtual desktop doesn't work anymore.
I tried both using a copy of old xorg.conf file and recreating it via xorgconfig and xorgsetup, alas, to no avail. The server starts correctly, but the desktop is limited to 1024x768. No complaints about the "Virtual 1600 1200" line can be found in X logs.

I have a Intel 915 video card and, of course, I configured xorg.conf to use the "i810" driver. I don't use 955resolution, since it doesn't work (I tried it some time ago).

Is virtual desktop still supported in new version of X?
Is there anyone else who uses it?

Any suggestion appreciated.

Thank you all,
Anyone who cannot cope with mathematics is not fully human.
At best he is a tolerable sub-human who has learned to wear
shoes, bathe, and not make messes in the house.
   -Robert Heinlein

Boardwalk for $500? In 2007? Ha! Play Monopoly Here and Now (it's updated for today's economy) at Yahoo! Games.  

More information about the xorg mailing list