Trying to get TV output working with Trident video card

Jonathan Schuster jonathan.p.schuster at
Sun Sep 16 16:40:33 PDT 2007

Hi, I'm trying to get TV output working, using a Trident CyberAlladin
card (although it shows up in lspci as CyberBlade), but the output I
get on the TV just shows one vertical strip of my screen repeated over
and over next to itself, and it's really fuzzy as well. To explain
better, if what's on my screen normally looks something like this:
| abc |
| def  |
| ghi  |

What I see on the TV looks like this:
| bbb |
| eee |
| hhh |

I'm using the trident driver, and I've tried several different
combinations of the TVSignal and TVChipset options in xorg.conf, but
all with the same result. When I'm in Windows on this same computer,
TV output works fine. I've looked around a lot on Google and
everything, but I can't seem to find anyone else who has had this
issue. I've attached both my xorg.conf and Xorg.0.log. If it helps,
here's the output from lspci:

00:00.0 Host bridge: ALi Corporation M1672 Northbridge [CyberALADDiN-P4]
00:01.0 PCI bridge: ALi Corporation PCI to AGP Controller
00:04.0 IDE interface: ALi Corporation M5229 IDE (rev c4)
00:06.0 Multimedia audio controller: ALi Corporation M5451 PCI AC-Link
Controller Audio Device (rev 02)
00:07.0 ISA bridge: ALi Corporation M1533/M1535 PCI to ISA Bridge
[Aladdin IV/V/V+]
00:08.0 Bridge: ALi Corporation M7101 Power Management Controller [PMU]
00:09.0 Modem: ALi Corporation M5457 AC'97 Modem Controller
00:0a.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL-8139/8139C/8139C+ (rev 10)
00:0c.0 USB Controller: NEC Corporation USB (rev 43)
00:0c.1 USB Controller: NEC Corporation USB (rev 43)
00:0c.2 USB Controller: NEC Corporation USB 2.0 (rev 04)
00:10.0 CardBus bridge: Texas Instruments PCI1410 PC card Cardbus
Controller (rev 01)
00:11.0 CardBus bridge: Toshiba America Info Systems ToPIC100 PCI to
Cardbus Bridge with ZV Support (rev 33)
00:12.0 System peripheral: Toshiba America Info Systems SD TypA
Controller (rev 05)
01:00.0 VGA compatible controller: Trident Microsystems CyberBlade
XPAi1 (rev 82)

As for any other information, I'm running Ubuntu on a Toshiba
Satellite A25-S207 laptop. I'd greatly appreciate any help. Thank you.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: xorg.conf
Type: application/octet-stream
Size: 4843 bytes
Desc: not available
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Xorg.0.log
Type: text/x-log
Size: 41544 bytes
Desc: not available
URL: <>

More information about the xorg mailing list