Xorg-7.3 and Touchscreen

Santhosh N san.mlists at gmail.com
Thu Sep 27 23:04:14 PDT 2007


I am trying to get a touchscreen to work with Xorg-7.3's
xorg-server-1.4. I need help in figuring out how to do it. I have been
able to get the same to work with the Kdrive server.

I tried adding the following section in the /etc/X11/xorg.conf file:
Section "InputDevice"
     Identifier "Touchscreen0"
     Driver "evdev"
     Option "Device" "/dev/input/event1"

But the xorg-server fails loading evdev with the following messages:
(==) Using config file: "/etc/X11/xorg.conf"
dlopen: /lib/xorg/modules/input//evdev_drv.so: undefined symbol:
(EE) Failed to load /lib/xorg/modules/input//evdev_drv.so
(EE) Failed to load module "evdev" (loader failed, 7)
(EE) No Input driver matching `evdev'

I had tried the same in Xorg-7.2's xorg-server and was able to get the
touchscreen to work. Also, I need to know about using the Tslib in the
xorg-server. This is because of using the filters provided by Tslib.

Any help in this regard is welcome...

Thanks in advance,
-Santhosh N

More information about the xorg mailing list