xorg hang after resume

Doron Fediuk doron.fediuck at gmail.com
Thu Aug 7 02:42:02 PDT 2008

Thanks Colin.
I managed to ssh my machine after resume (while it hangs).
I tried to stop the xdm service. But it failed.
So I checked with top: X was using 97-99% cpu.
I managed to kill most of kde's processes. 
I tried to kill X, but even kill -9 wouldn't work ! (first
time I see a process which won't go down for kill -9).
Eventually I had to reboot (better then cold-start..).

As for vbetool, I know it helps, but mostly for other HW.
So far everything worked smoothly without it, and I prefer to
use it only as a last resort (and not sure it'll help...).

Any idea how to resolve this ?
Thanks !

Colin Guthrie wrote:
> > Thanks Sérgio.
> >
> > I'm referring to suspend and resume from RAM.
> > I'm using sys-power/suspend-0.8 in Gentoo portage (comes from
> > http://suspend.sourceforge.net/), which works well AFAIK. I checked with
> > console, and resume from console works fine. Further more, I implemented
> > your advices regarding "AGPMode" (using 4 now), and disabled
> > "AGPFastWrite". Couldn't find a way to fix the following:
> > [dri] Found DRI library version 1.3.0 and kernel module version 1.28.0
> >
> > I also removed evdev and radeonhd drivers, since I'm not using it.
> > Behavior is still the same, and logs show no information about the hang
> > reason. The strange thing is, that display starts to paint the windows (I
> > can see the borders), and mouse is working, but then display freezes and
> > keyboard is stuck (I need to cold start the machine every time- not
> > good...)
> >
> > I'd appreciate any help !
> Have you fiddled around with the vbetool options? You may need to run it
> after resume. There is a list/db of what actions to take as part of the
> hal package on other distros, e.g. my Dell has it's tweaks, ifs and buts
> in: /usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-dell.fdi
> which is part of the hal-info package.
> I use power_management.quirk.vbe_post but you can also try
> power_management.quirk.vbemode_restore (as our h/w is totally different!)
> You can try these options via the command line as root, but I forget
> how, but it will be via hal-set-property.
> Also you should confirm that it is purely a display problem by SSH'ing
> in from another machine on the network to make sure it is doing stuff
> properly. If you can't do that you can try a "sleep 3m; mplayer
> /some/music/file.mp3" before you suspend and see if you can hear it when
> you resume ;)
> HTHs
> Col

More information about the xorg mailing list