problems of starting X

He, Shuang shuang.he at
Thu Aug 21 23:10:24 PDT 2008

Wayne wrote:
> Hi all,
> I've successfully built xserver of git version by I put the 
> source in /opt/src/ and
> the binary files in /opt/modular/. Before I ran X, I typed
>     export LD_LIBRARY_PATH=/opt/modular/lib
> In, it says I have to typed
>     startx -- /opt/modular/bin/Xorg
> I could enter X-window by this command, but is it right?
> I mean how do I make sure if I'm running my new-xserver or old-xserver.
> I typed X -version, but it showed My new-xserver is
> I typed /opt/modular/bin/X -version, and I got
> And then I typed /opt/modular/bin/startx to enter X-window, but it just
> showed three console windows on the screen with a ugly small click.
> And the mouse pointer is X.
> How can I run my new-xserver correctly?
You probably need to change ModulePath in xorg.conf  to like 

> Thanks
> Wayne
> ------------------------------------------------------------------------
> Connect to the next generation of MSN Messenger  Get it now! 
> <> 
> ------------------------------------------------------------------------
> _______________________________________________
> xorg mailing list
> xorg at

More information about the xorg mailing list