Fedora 9 Problems with Real Player 11 and Acrobat 8 Plugins for FF

Michael B Allen ioplex at gmail.com
Fri Aug 29 10:55:52 PDT 2008


I'm having two problems that I'm starting to think might be related to video.

System is:

Thinkpad T61 GM965/GL960
Fedora 9 i686
Firefox 3.0.1

1) When visiting NASA TV, the latest Real Player 11 plugin for Firefox
will load and play with sound for about 1 second. Then the plugin
display viewport goes light grey and I hear nothing.

If I run realplay without the browser with the same stream I get an
error shortly after it finishes bufferring:

$ realplay

** (process:10752): WARNING **: Unsupported locale en_US.utf8! Please
use a locale with .UTF-8 suffix! For example: export

Opening ALSA PCM device default
Opening ALSA PCM device default
The program 'realplay.bin' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 41 error_code 8 request_code 141 minor_code 13)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

2) When clicking on a PDF link the latest Acrobat 8 plugin for Firefox
will load and the status bar reports "done" but it displays nothing
but a light grey background. However, if I press Alt-Tab as though I
were cycling through windows the PDF is suddenly displayed properly in
the browser.

If I run acroread without the browser with the same document from a
local file, it runs great with the exception of seemingly harmless and
unrelated "bug-buddy" error "Failed to load module "gnomebreakpad"".

Has anyone experienced these problems?

Can anyone confirm that these programs actually work w/ Fedora 9?


More information about the xorg mailing list