ATi X300SE - zaphod stopped working

Jan Kasprzak kas at
Mon May 12 02:14:42 PDT 2008

Dave Airlie wrote:
: On Mon, May 12, 2008 at 6:34 PM, Jan Kasprzak <kas at> wrote:
: >  I have upgraded my system from Fedora 8 to Fedora 9 (pre release), and
: >  my dual-screen (Zaphod) X does not work anymore: when the dual-screen
: >  layout is in use, the X server fails to start with
: >
: >  (EE) RADEON(1): Unable to map MMIO aperture. Invalid argument (22)
: You need to grab the F9 ati driver from updates-testing if its available yet.
: or there is a build in koji

	I have tried this one (thanks!) - it is better, but still not
fully working: the X server starts with two screens, but the second
one has its refresh times out of range of my monitor (it displays
"74.5kHz/60Hz out of range"). Moreover, when I try to move the cursor
to the secondary head, it locks up (the cursor disappears from the primary
head and cannot be moved back). When the last X client disconnects,
the server crashes with the following backtrace:

0: X(xf86SigHandler+0x65) [0x479fe5]
1: /lib64/ [0x2b16c3f1b2a0]
2: X [0x4a6485]
3: X [0x4a7066]
4: X(xf86_reload_cursors+0x10c) [0x4a6aec]
5: X(xf86CrtcSetMode+0x3fd) [0x4a420d]
6: X(xf86SetDesiredModes+0x1bd) [0x4a469d]
7: /usr/lib64/xorg/modules/drivers// [0x2b16c65fd1d7]
8: X(AddScreen+0x1c9) [0x42bf09]
9: X(InitOutput+0x216) [0x4623c6]
10: X(main+0x286) [0x42c6a6]
11: /lib64/ [0x2b16c3f0732a]
12: X(FontFileCompleteXLFD+0x279) [0x42bc59]

Fatal server error:
Caught signal 11.  Server aborting

	I can provide more debugging info if requested.



| Jan "Yenya" Kasprzak  <kas at { - work | - private}> |
| GPG: ID 1024/D3498839      Fingerprint 0D99A7FB206605D7 8B35FCDE05B18A5E |
|    Journal: |
>>  If you find yourself arguing with Alan Cox, you’re _probably_ wrong.  <<
>>     --James Morris in "How and Why You Should Become a Kernel Hacker"  <<

More information about the xorg mailing list