Michael Verret michael.verret at gmail.com
Thu May 22 06:58:21 PDT 2008

On Thu, May 22, 2008 at 8:17 AM, Deepak Bhatia
<deepak.bhatia at nechclst.in> wrote:
> Thanks Reed,
> Question 1- But we want to remove X11 Release 7.1 completely and put X11
> Release 7.3?
> Question 2- Also we are facing errors when we install
> "xorg-server-1.4.tar.bz2" ? The errors are shown in error_file.txt
> attached.
> Mainly the error is
> checking for PIXMAN... configure: error: Package requirements (pixman-1
>>= 0.9.5) were not met:
> Best Regards
> Deepak Bhatia


You have to build things in certain orders based on the dependency
requirements. For example pixman is a dependency of xserver so it must
be built and installed first. You should study the source files /
build scripts of a similar distribution or read the software's config
files looking for requirements and create a tree of dependencies in
your notes. There is an old script in the wiki that did this to track
dependencies for a person moving from X11R6 to X11R7 and it may be
useful to you.

This is old an outdated but could be a tremendous help to you and give
you some perspective:



More information about the xorg mailing list