xf86-input-evdev-1.2.0 broken

Thomas Ilnseher illth at gmx.de
Mon May 26 07:57:59 PDT 2008

Am Montag, den 26.05.2008, 21:46 +0930 schrieb Peter Hutterer:
> On Mon, May 26, 2008 at 01:01:01PM +0200, Thomas Ilnseher wrote:
> > I got a new trust 15351 bluetooth mouse.
> > when installing the mouse, I noticed that only the Y axis worked,
> > while the X axis did not. 
> can you please post your Xorg.0.log? I'm pretty sure the axis autodetection
> code is going awry.
will do it, soon.
> > I downgraded to 1.1.5-r2, which finally solved any problems. Therefore 
> > xf86-input-evdev-1.2.0 is to blame.
> You should also be able to upgrade to evdev 2.0 from git, it is a bit more
> resistant to funky devices.
Ok, will do this first. There is a new problem with 1.1.5:
when the mouse isn't moved for some minutes, it disconnects itself.
=> xorg crashes.

I don't think the mouse is that funky. it got 2 rel axes (X and Y), a
hwheel, (a vwheel that's not physically available, but in the
descriptors grrr...), and 5 mouse buttons.

> Cheers,
>   Peter
Thomas Ilnseher <illth at gmx.de>

More information about the xorg mailing list