xf86-input-evdev-1.2.0 broken

Thomas Ilnseher illth at gmx.de
Sat May 31 03:56:36 PDT 2008

Am Freitag, den 30.05.2008, 20:48 +0200 schrieb Jelle de Jong:
> Thomas Ilnseher wrote:
> > I got a new trust 15351 bluetooth mouse.
> > when installing the mouse, I noticed that only the Y axis worked,
> > while the X axis did not. 
> > 
> > I tracked the mouse input through the kernel, and I eventually noticed
> > that the kernel's evdev interface outputs the axis movements. therefore 
> > I need to blame evdev. 
> > 
> > I downgraded to 1.1.5-r2, which finally solved any problems. Therefore 
> > xf86-input-evdev-1.2.0 is to blame.
> > 
> I am just curious, i got the 15606 bluetooth mouse with in my eyes is 
> the same as yours:
> http://www.trust.com/products/product_detail.aspx?item=15351
mine is exactly the 15351 aka 5700Rp that is linked by this linl (btw
note the item=15351).
> I got no real issues with this mouse, cursor, and scroll, dpi button are 
> all working. with the hidd driver, did not try the input hcid api yet.
The issue was that:
a) only the y axis worked.
b) the side buttons were remapped to button 8 and 9.

b) is only a small nuisance(xmodmap), but a) hurts ;)

i used "hidd --search", then connected the mouse with the button on the

Both issues were generated by the fact that the hid descriptors of the
mouse contained some garbage (ie. a Consumer.HWheel, which got mapped to
the 6/7 buttons, and some 0006.0020 which was reported as an absolute
axis and got mapped by the kernel to abs.misc).

That confused xf86-input-evdev-1.2.0 (1.1.5 works fine), so that the X
axis disappeared. xf86-input-2.0.0 should also be more tollerant against
such issues.

using 1.1.5 was however no option, because the mouse will, when unused
for some time, eventually disconnect itself from the PC (I think to save

this makes the device disappear. when input hotplugging is enabled in
the xserver, and this happens, 1.1.5 will crash the whole xserver.

> What exactly is your issue? I am using debian sid btw.
> The only issue i can find are the little back and forward button on the 
> side, they do not behave the same on all applications.
> Kind regards,
> Jelle
Thomas Ilnseher <illth at gmx.de>

More information about the xorg mailing list