[xorg-server-1.5] build fails against mesa GIT master

Tobias Jakobi liquid.acid at gmx.net
Sat May 31 07:41:35 PDT 2008

Donnie Berkholz wrote:
> On 20:31 Thu 29 May     , Tobias Jakobi wrote:
>> Hi Donnie,
>> libxcb for example is requiering a python-2.5 version, these are currently 
>> keyworded on gentoo. The current ebuild doesn't check for the python 
>> version, so it fails on my system. I'm not very keen on updating python 
>> anyway, but if that's the only way to get new X env to build I'm going to 
>> try that.
> Looks like it requires Python 2.5:
>   libxcb/configure.ac:AM_PATH_PYTHON([2.5])
>   proto/configure.ac:AM_PATH_PYTHON([2.5])
> I updated the ebuilds to reflect that.
> Thanks,
> Donnie
Hi Donnie,

after some massive revdep-rebuilds (libxcb-xlib versus libxcb) I managed 
to compile xorg-server. It works now, but a few problems remain.

1) the synaptics driver doesn't build anymore, I was already using a 
9999 version from Hanno Boeck's overlay which worked prior to the MPX 
merge and all the XINPUT changes.
I already contacted Hanno and asked him about the problem and also the 
maintainer of the original synaptics driver.

2) xf86-video-vesa-1.3.0 doesn't compile. That's not really a problem 
because it's only a fallback driver in case I can't get the intel to 
work. Going to try the source from GIT.

Everything else works and both X and mesa are pretty stable. EXA 
performance is acceptable, but could be better. Seems like we have to 
wait for batchbuffers until this changes :-)


More information about the xorg mailing list