xf86-video-intel: suspend to ram does not work

Keith Packard keithp at keithp.com
Sun Nov 9 16:41:54 PST 2008

On Sun, 2008-11-09 at 15:41 +0100, Christoph Schied wrote:
> Hi!
> My System crashes after resuming from suspend to ram. It shows the
> Xserver, but freezes then.
> When using xf86-video-vesa, suspend works without problems.
> I tried xf86-video-intel-{2.5.0,2.4.2} and the appropriate xserver
> versions.
> I also tried kernel versions,, 2.6.28-rc3 but it
> seems like it doesnt make a difference.
> Im using a Thinkpad X200, which includes the Intel GMA X4500MHD.

I posted a patch to save/restore MCHBAR_RENDER_STANDBY which made my
X200s happy. Let us know if this helps for you.

keith.packard at intel.com
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0001--drm-i915-Save-restore-MCHBAR_RENDER_STANDBY-on-GM9.patch
Type: application/mbox
Size: 2297 bytes
Desc: not available
URL: <http://lists.x.org/archives/xorg/attachments/20081109/6232ccbf/attachment.bin>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
URL: <http://lists.x.org/archives/xorg/attachments/20081109/6232ccbf/attachment.pgp>

More information about the xorg mailing list