USB keyboard with Xfbdev (again)

Stuart Hughes seh at
Fri Nov 14 06:12:33 PST 2008

Hi Cliff,

I saw your posting here:
and wondered if you or anyone else managed to resolve this.

I'm cross compiling xorg-server-1.4 for a powerpc 7400 (MAC G4) and
Xfbdev starts and the mouse works (eventually), but I get nothing from
the USB keyboard (I started twm and tried typing an xterm).

I'm starting it like this and see:

# Xfbdev -mouse mouse -keybd xkb
Couldn't find keyboard driver keybd
Couldn't find keyboard driver xkb

I've tried other combinations, but nothing seems to work.  I'm passing
the following to configure when I build it (all one line):

./configure --prefix=/usr --host=powerpc-linux --build=i686-pc-linux-gnu
--enable-composite --enable-kdrive --disable-dri --disable-xinerama
--disable-xf86misc --disable-xf86vidmode --disable-xorg
--disable-xorgcfg --disable-xnest --disable-xvfb --disable-xevie
--disable-xprint --disable-xtrap --enable-xfbdev --disable-dmx
--enable-builtin-fonts --disable-dbus --disable-ipv6 --enable-xkb

Any ideas?

Regards, Stuart

More information about the xorg mailing list