Radeon DPMS problems? backlight turns back on after a minute

Lowell Alleman lowell at allemansonline.com
Mon Apr 6 16:29:38 PDT 2009

Are there any known issues with DPMS not working properly with the latest
radeon driver?  I've found some old bugs that sound similar, but don't
exactly match and the workarounds I've found seem to make a difference.
 Here is what I'm experiencing:

My laptop (IBM T42, r300) LCD will not going into power saving mode on its
own.  If I force it go into one of these modes, it only stays in that mode
for a short period of time (a few seconds to a couple of minutes) before the
screen turns back on again. I'm pretty sure this isn't due to any
keyboard/mouse events (since the screen saver doesn't
pop up a login dialog) and I don't see any new events /var/log/acpid that
correlate to the LCD being re-enabled.  However, every time the LCD turns
back on, I do see the following message in the Xorg.0 log file:  "enable
LVDS".  It appears that the X server still thinks that the DPMS mode is
enabled, because "xset q" says that the monitor is still in "Suspend" (or
whatever mode I forced it to be in) even after the LCD was turned on again.

Here are some additional details about my setup, and what I've tried:

Relevant output from "xset q":
DPMS (Energy Star):
 Standby: 600    Suspend: 660    Off: 1200
 DPMS is Enabled
 Monitor is On

After the display has been disabled using "xset force suspend" the display
shuts down.  If you check "xset q" it now reports "Monitor is in Suspend".
 A minute or so later the LCD is turned back on.  Now I can see screensaver
(which is DPMS-aware, and therefore has been paused to save CPU cycles).  At
this point, "xset q" still shows "Monitor is in Suspend".

I've tried switching between EXA and XAA acceleration.  As of radeon v6.12.0
XAA says it is not supported any more, but EXA doesn't appear to be the
default yet.  (Not sure what that means; but in both cases this problems
still occurs).  I've also tried adding the "NoPM" option, as I found as an
old workaround suggested, but that didn't make a difference either.


X.Org X Server 1.5.2
Radeon driver:  6.12.0  (I compiled this locally for improved
performance in latest release)
Linux 2.6.27-11-generic #1 SMP Thu Jan 29 19:24:39 UTC 2009 i686 GNU/Linux
Kubuntu 8.10
KDE 4.1.4

I can provide additional info (xorg.conf and Xorg.0.log) if this is an
unknown situation and those would be helpful to have.


- Lowell
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.x.org/archives/xorg/attachments/20090406/dfa483e3/attachment.html>

More information about the xorg mailing list