Radeon DPMS problems? backlight turns back on after a minute

Gene Heskett gene.heskett at verizon.net
Tue Apr 7 09:28:02 PDT 2009

On Tuesday 07 April 2009, Lowell Alleman wrote:
>On Tue, Apr 7, 2009 at 3:05 AM, Magnus Kessler <Magnus.Kessler at gmx.net> 
>> On Tuesday 07 April 2009, Lowell Alleman wrote:
>>> Are there any known issues with DPMS not working properly with the latest
>>> radeon driver?  I've found some old bugs that sound similar, but don't
>>> exactly match and the workarounds I've found seem to make a difference.
>>>  Here is what I'm experiencing:
>>> My laptop (IBM T42, r300) LCD will not going into power saving mode on
>>> its own.  If I force it go into one of these modes, it only stays in that
>>> mode for a short period of time (a few seconds to a couple of minutes)
>>> before the screen turns back on again. I'm pretty sure this isn't due to
>>> any keyboard/mouse events (since the screen saver doesn't
>>> pop up a login dialog) and I don't see any new events /var/log/acpid that
>>> correlate to the LCD being re-enabled.  However, every time the LCD turns
>>> back on, I do see the following message in the Xorg.0 log file:  "enable
>>> LVDS".  It appears that the X server still thinks that the DPMS mode is
>>> enabled, because "xset q" says that the monitor is still in "Suspend" (or
>>> whatever mode I forced it to be in) even after the LCD was turned on
>>> again.
>>> Here are some additional details about my setup, and what I've tried:
>>> Relevant output from "xset q":
>>> DPMS (Energy Star):
>>>  Standby: 600    Suspend: 660    Off: 1200
>>>  DPMS is Enabled
>>>  Monitor is On
>>> After the display has been disabled using "xset force suspend" the
>>> display shuts down.  If you check "xset q" it now reports "Monitor is in
>>> Suspend". A minute or so later the LCD is turned back on.  Now I can see
>>> screensaver (which is DPMS-aware, and therefore has been paused to save
>>> CPU cycles).  At this point, "xset q" still shows "Monitor is in
>>> Suspend".
>>> I've tried switching between EXA and XAA acceleration.  As of radeon
>>> v6.12.0 XAA says it is not supported any more, but EXA doesn't appear to
>>> be the default yet.  (Not sure what that means; but in both cases this
>>> problems still occurs).  I've also tried adding the "NoPM" option, as I
>>> found as an old workaround suggested, but that didn't make a difference
>>> either.
>>> Versions:
>>> X.Org X Server 1.5.2
>>> Radeon driver:  6.12.0  (I compiled this locally for improved
>>> performance in latest release)
>>> Linux 2.6.27-11-generic #1 SMP Thu Jan 29 19:24:39 UTC 2009 i686
>>> GNU/Linux Kubuntu 8.10
>>> KDE 4.1.4
>>> I can provide additional info (xorg.conf and Xorg.0.log) if this is an
>>> unknown situation and those would be helpful to have.
>>> Thanks,
>>> - Lowell
>> Hi Lowell,
>> this was a bug in the KDE 4 screensaver code [0]. It is certainly fixed in
>> the latest version of KDE. Try updating to KDE 4.2.1 or above.
>> HTH,
>> Magnus
>> [0] http://bugs.kde.org/show_bug.cgi?id=165265
>> _______________________________________________
>> xorg mailing list
>> xorg at lists.freedesktop.org
>> http://lists.freedesktop.org/mailman/listinfo/xorg
>Hey Magnus,
>Thanks for that link.  I do think that that bug is *part* of my
>problem, but not *all* of it.  (I plan on upgrading to Kubuntu 9.04,
>which has KDE 4.2.x once it is released last this month.)  Based on
>the info in that bug report, I ran the following test:
>I set my screen saver to come on after 5 minutes.  Then I ran "xset
>dpms 5 10 15".  The screen does blank after 5 seconds, but it then
>comes back on after about 2 seconds, with the screen saver visible in
>the background (which was unexpected.)  Then at the 10 second mark,
>the screen turns off again and comes back on after a few minutes.
>One general observation is that it seems like the first time the LCD
>enters a power saving mode, it lasts for only a few seconds.  Then
>each additional switch into powersavings mode lasts for about a minute
>or two.  (When I say "first time", I mean after an Xorg restart.)
>Just to rule out KDE as the whole problem, I'm going to try starting
>up in a different environment; perhaps some failsafe xterm mode.  I'll
>let you know what I find.
>- Lowell

I have had an instance or two where old batteries in the mouse caused a one 
pixel movement when the mouse wasn't being touched. hat will unblank it.  I 
changed batteries a couple of times, then changed the mouse. End of problem...
>xorg mailing list
>xorg at lists.freedesktop.org

Cheers, Gene
"There are four boxes to be used in defense of liberty:
 soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
"When anyone says `theoretically,' they really mean `not really.'"
 -- David Parnas

More information about the xorg mailing list