How to install Xnest in slax?

michael mitzelburg michael.mitzelburg at
Wed Apr 8 00:56:49 PDT 2009

Hi all,

I am actually have already seen a lot of similiar problems with those who
uses Xnest. However, I can not figure this problem for slax distro.  The
output error for #Xnest -query :1 is below :

_XSERVTransSocketOpenCOTSServer: Unable to open soc Xorg.1.log ket for inet6
_XSERVTransOpen: transport open failed for inet6/slax:10
_XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6
XDMCP warning: INET6 UDP socket creation failed
Could not init font path element /usr/share/fonts/OTF, removing from list!
Could not init font path element /usr/share/fonts/Type1, removing from list!

Fatal server error:
could not open default font 'fixed'

I tried to copy a folder of Type1 font from Ubuntu to /usr/share/fonts in
Slax, however it did not work (the same error still occured). I managed to
remove the "could not init font..." by commenting them in Xorg.conf, however
a same problem still occured for "could not open default font 'fixed'".  

In the FAQ section of X, it is stated that I need to find a 'fixed' font and
put it in /usr/share/font/misc. However, I could not find any 'fixed' font
in Ubuntu distro (tried to copy the file to slax). Where can I get a 'fixed'

I attach my error (xorg.conf).

Thank you

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Xorg.0.log
Type: application/octet-stream
Size: 35753 bytes
Desc: not available
URL: <>

More information about the xorg mailing list