xrandr tmds_pll option with radeon?

Robert Uhl r.uhl at xaipete.de
Fri Apr 10 02:38:40 PDT 2009

Hi there,
last night i updated x.org-server to 1.5.3 on my Thinkpad R51 running
Gentoo Linux, Kernel, with radeon driver.
Before the update i executed the following at fvwm startup:

xrandr --output DVI-0 --set tmds_pll driver
xrandr --output DVI-0 --mode 1600x1200 --rate 60.0

Without this, my NEC 2090UXi TFT-Display attached via Dockingstation only
allows 1280x1024 as maximum resolution. If i tried to do
xrandr --output DVI-0 --mode 1600x1200 --rate 60.0
the display turns black and doesn't show anything.
After searching in google, i found a post on a mailinglist with
xrandr --output DVI-0 --set tmds_pll driver
and with this command everything worked fine.

But now with the new xorg-server version xrandr says:

$ xrandr --output DVI-0 --set tmds_pll driver
X Error of failed request:  BadName (named color or font does not exist)
  Major opcode of failed request:  150 (RANDR)
  Minor opcode of failed request:  11 ()
  Serial number of failed request:  19
  Current serial number in output stream:  19

So it is not possible to set the TFT resolution to 1600x1200, again
black display.

Maybe someone knows where the tmds_pll option is gone?

Kind regards,

Robert Uhl

More information about the xorg mailing list