Debian Sid with NVidia card : Xorg cannot start...

David BERCOT debian at
Mon Apr 13 01:22:43 PDT 2009


I'm new on this list and this is my first message.
I hope it's not a "classical" error but I had a (quick) look in the
archives and I did not found any solution...

First of all, I use Debian Sid with a 2.6.29 kernel. I've tried to
install the non-free NVidia drivers but it seems that there is a
bug with the 2.6.29 kernel. So, I have to use the free drivers
(expecting for the bug to be resolved soon ;-))).

So, I've tried to install Lenny. Everything was OK (but the resolution
that Xorg uses is 1600x1200 instead of the real resolution of
1680x1050 !!!). Then, I've tried Squeeze and it was ok too (same Xorg
version : 1:7.3+18). And, last, I've tried with Sid and Xorg can't
start !!! Now, the Xorg version is 1:7.4+1. My Xorg.conf is empty (not
really, but there are no information about my card, the driver to use,
etc...). The error is :

X.Org X Server 1.6.0
Release Date: 2009-2-25
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6;29-1-amd64 x86_64 Debian
(EE) No devices detected.
Fatal server error:
no screens found

Do you have any idea ?



More information about the xorg mailing list