Old System, New Install Isuue

Magnus Kessler Magnus.Kessler at gmx.net
Tue Apr 28 22:46:25 PDT 2009

On Tuesday 28 April 2009, James Butler wrote:
> Hello!
> Fedora Core 4 (Linux 2.6.17-1)
> yum install xorg-x11 (v.6.8.2)
> This is a "headless" dedicated system with FC4 pre-installed by the
> hosting service. It is one of hundreds in a remote rack. I have no
> direct access to the system.
> I have been running and updating this system using the CLI for about 3
> years, however I now need some sort of X system running if I want to run
> VisualChat software for my users. Its Java programming requires a
> windows manager (X) when run on a Linux box.
> Since I had no X installed on this system, I used yum to install it,
> seemingly without any issues. All of the dependencies (i.e. xinit) were
> successfully installed, as well.
> After installing xorg-x11, I ran "X -configure" to generate a
> system-specific config file. I am now stuck with the server failing to
> start and generating no error messages that I can act upon.
> Executing 'X -config /user/xorg.conf.new', I see this midway through the
> Xorg.0.log file:
> ======== Xorg.0.log snippet start ==========
> (II) I810(0): Display Info: CRT: attached: FALSE, present: FALSE, \
>   size: (0,0)
> ...
> (II) I810(0): Currently active displays on Pipe A:
> (II) I810(0): 	CRT
> (==) I810(0): Display is using Pipe A
> ...
> (II) I810(0): Will use BIOS call 0x5f05 to set refresh rates for CRTs.
> ======== log end ==========
> And then this at the end of the log (when everything halts):
> ======== Xorg.0.log snippet start ==========
> ...
> (WW) I810(0): Successfully set original devices
> (WW) I810(0): Setting the original video mode instead of restoring \
>   the saved state
> (WW) I810(0): Extended BIOS function 0x5f05 failed.
> (II) I810(0): BIOS call 0x5f05 not supported, setting refresh with \
>   VBE 3 method.
> (II) I810(0): xf86UnbindGARTMemory: unbind key 7
> ...
> {unbind key 0,1,3,2,4,5,6 follow}
> ...
> (WW) I810(0): Successfully set original devices (2)
> ======== log end ==========
> boom. It gets no further.
> So a BIOS failure to call 0x5f05 would seem to indicate a problem
> getting the (non-existent) monitor to initialize.
> Is it possible to run X without an attached monitor, mouse or keyboard?
> Shall I post the full Xorg.0.log and my xorg.conf.new file?
> I appreciate any guidance.
> James

Hi James,

depending on the exact needs of the Java software you want to install you 
might be able to do it without an X environment at all.

Have you tried running Java in headless mode (java -Djava.awt.headless=true) 
as documented on 
http://java.sun.com/developer/technicalArticles/J2SE/Desktop/headless/ ? I 
presume that you only need a graphical environment during installation and 
that the software is later used over the web. Some installers I've seen fall 
back to character output when run in headless mode.



-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 198 bytes
Desc: This is a digitally signed message part.
URL: <http://lists.x.org/archives/xorg/attachments/20090429/673817e2/attachment.pgp>

More information about the xorg mailing list