can't select in menus of xterm, xfig, xfontsel, editres, xman, gv, ghostview

G. Paul Ziemba pz-xorg at
Thu Aug 13 11:07:43 PDT 2009

Hi, I hope someone has seen this issue before and can recommend a fix.

Versions: xorg-7.3_2 xorg-libraries-7.3_2 xorg-server-1.4.2,1

On one of my systems, the pulldown menus on a collection of applications
have become unresponsive - that is, items do not get highlighted when
the mouse cursor is over them and I can not select any items. They used
to work, and I don't know what changed.

Affected applications: xterm,xfig,xfontsel,editres,xman,gv,ghostview
and probably others.

I saw several postings indicating an issue with Num Lock, and I tried
using the menus after turning it on, and after turning it off again,
but no improvement. I tried

    Option "ServerNumLock" "on"

in the keyboard section of my xorg.conf but that didn't seem to
make any difference.

The problem seems to be specific to the X server. I first noticed the
issue on my desktop machine, let's call it "desktop-flake". If I fire
up X on another desktop and run the application remotely from
desktop-flake, xterm menus work correctly. This makes me think it's
not an issue with the way the applications are built.

On desktop-flake, I also tried a different window manager (I normally
use fvwm2, but tried twm): no improvement.

I restarted X. No improvement.

I rebuilt libXaw3D-1.5E_2 and rebuilt xfig. I also rebuilt xfig
against plain libXaw. Those things didn't help either.

I found a few hits on the web where others had similar problems, but
couldn't find any solutions:

Suggestions welcome!
G. Paul Ziemba
FreeBSD unix:
11:06AM  up  2:22, 3 users, load averages: 0.41, 0.27, 0.20

More information about the xorg mailing list