make[4]: *** No rule to make target `-lselinux', needed by `

Justin P. Mattock justinmattock at
Wed Aug 19 10:43:05 PDT 2009

Nix wrote:
> On 11 Aug 2009, Justin P. Mattock told this:
>> seems this is not working over here.
>> I've tried LIBS=-L/lib64 LDFLAGS=-L/lib64
>> I've sent a post to selinux as well
>> seems they cant reproduce this.
> The .so symlinks (well, nearly always symlinks) should go in /usr/lib64,
> even if the libraries they relate to are in /lib64. The linker scripts
> normally search /usr/lib{,32,64} and /lib{,32,64} but that is not an
> absolute. They *do* always look in /usr/lib.
> And you want to set LDFLAGS, not LIBS, unless you want the linker to look
> in /lib64 for only *some* libraries.
Thanks for the info.
I must admit building everything
in lib64 /usr/lib64 is more work than
anticipated. As for this issue
here is the link to the patch that I used
(thanks to dan nicholson)
it worked

xserver compiles with selinux support,
policy turns on and the xserver started generating

Justin P. Mattock

More information about the xorg mailing list