3dfx/Westinghouse LCD configuration broken by upgrade

Kevin O'Gorman kogorman at gmail.com
Sat Jul 4 09:31:45 PDT 2009

I'm using Ubuntu and Gentoo Linux, a 3dfx Voodoo 3 board and a
Westinghouse LCD monitor model LCM-20v5 through a KVM switch (the
Ubuntu and Gentoo are two different hosts).

I had a working configuration with xorg on both, they have both been
broken by recent upgrades to xorg.  I can no longer get X to boot up
to a working GUI.

For the moment, I'll focus on the Ubuntu situation

I have tried the output of Xorg --configure
(http://pastebin.ca/1483889)    (log file http://pastebin.ca/1483907)
I have tried the old xorg.conf  (http://pastebin.ca/1483892) (log file
I have tried and empty xorg.conf. (log file http://pastebin.ca/1483925)

The results are the same with all  three: the Ubuntu bootup screen is
normal (Graphical: Ubuntu logo, large name in an outline font, and a
"cylon" progress bar with a bright segment moving back and forth)
later followed by a brief moment with the usual Ubuntu "busy" cursor,
then a black screen with occasional flickers of slightly gray).
Useless, but I think I'd be satisfied with the mode that showed the
cursor -- it was about as small as I remember for a 1280x1024 mode.

The hardware is working to this extent: Dual-booting to windows 98 I
get 7 different video modes from 640x480 all the way up to 1280x1024.
Moreover, the Ubuntu live disk can at least find a 600x800 mode.

I suspect there's something about the newer X and the monitor itself,
rather than the video driver, because the Gentoo system also broke on
upgrade, and it uses an ATI Rage chipset on the motherboard.  The
results there are about the same.

How can I work to solve this?

Kevin O'Gorman, PhD

More information about the xorg mailing list