xkeyboard-config woes/keymap compile errors with new Git Xorg stack build

Joel Feiner jafeiner at gmail.com
Mon Jul 20 15:04:13 PDT 2009

I went to rebuild my Xorg stack from Git.  Since my old build has built 
up some cruft from being around for a while, I decided to make a new 
build into an empty install directory.  That is, I am rebuilding from 
scratch.  Everything worked except that when I run X, it dies 
complaining that it can't parse the XKB map:

(EE) Error compiling keymap (server-0)
(EE) XKB: Couldn't compile keymap
XKB: Failed to compile keymap
Keyboard initialization failed. This could be a missing or incorrect 
setup of xkeyboard-config.

Fatal server error:
Failed to activate core devices.

So I made sure the xkeyboard-config was up to date, compiled and 
installed. I also recompiled the X server (make distclean; ./configure; 
make; make install).  Still no luck.  I'm not really sure how to debug 
this problem because I know pretty much nothing about xkeyboard-config. 
  Is there a way to find out exactly what the problem is, and, of course 
how to fix it?

FWIW, I used this ./configure command for xkeyboard-config:

./configure --enable-maintainer-mode --prefix=/usr/local/xorg 
--enable-compat-rules --enable-xkbcomp-symlink 


- Joel

More information about the xorg mailing list