radeonhd stuff, missing function now?

Gene Heskett gene.heskett at verizon.net
Sun Mar 15 05:33:34 PDT 2009


Up till a week ago (approx) that script I wrote worked well to get me a much 
improved speed out of my x, but recently when I do the
 'modprobe -r drm;modprobe drm' there is a function missing.

And I'm stuck with an x driver that scrolls painfully slow.

From dmesg:
[135979.940024] [drm] Module unloaded
[135990.364368] drm: Unknown symbol init_mm

I have seen that previously during the build, but it worked anyway.  Now its

Also, a couple lines in the script that I just changed so as to have a backup 
copy to revert to, do not appear to be working, so here it is again, please 
critique the attachment.

Thirdly, I forgot to stop x before I did the module replacement & attempted 
reloads.  I take it that radeonhd is not dependent on radio or drm?  They are 
unloaded and x is till working.  Me goes off scratching head...

Cheers, Gene
"There are four boxes to be used in defense of liberty:
 soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
Nothing motivates a man more than to see his boss put in an honest day's work.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: radeonhd-updater.sh
Type: application/x-shellscript
Size: 1287 bytes
Desc: not available
URL: <http://lists.x.org/archives/xorg/attachments/20090315/917c16ba/attachment.bin>

More information about the xorg mailing list