Need help: Lost keyboard after xorg upgrade

Michael auslands-kv at
Sun Aug 8 00:43:40 PDT 2010


I use Debian SID on two laptops here. One works without any problem. The 
other has lost the keyboard in X after last dist-upgrade.

After start of KDM you see the login manager with the cursor blinking. You 
can move the mouse and position the cursor as well as mark any text. 
However, the keyboard does not change or enter any text, just as if there 
where no keyboard. (I tried using an external USB keyboard as well. Did not 
work either...)

The system is running without an xorg.conf file. I tried using one with 
keyboard definitions in, but it did not change anything.

I also tried running different kernels (2.6.31 to 2.6.34), but this does not 
have any effect. Would have been strange anyway, as the keyboard is working 
perfectly in the virtual console (also the USB keyboard when it is 

The new X.Org X Server is version 1.7.7. (I don't remember the old one that 
I had on the system that was running fine. It was quite a bit older, 

Can anybody help me? I have no idea what to do to get the keyboard back. :-(



-------------- next part --------------
A non-text attachment was scrubbed...
Name: Xorg.0.log
Type: text/x-log
Size: 25093 bytes
Desc: not available
URL: <>

More information about the xorg mailing list