Fatal IO Error 11

Huaxin Xu hxu at the3rdeye.com.au
Tue Aug 10 19:25:29 PDT 2010

Hi all,



When I run a gtk application I wrote myself, for approximately 1 in 10
times I could not get X window started. At other times the X window
starts and the program runs properly.


When this happens, I would get an error message on the virtual console


xxx(the application's name): Fatal IO Error 11 (Resource temporarily
unavailable) on X server :0.0.


Nothing seems relevant in /var/log/Xorg.0.log, nor could I find much
information about this particular error on the Web. Can someone provide
me with more information, e.g. what usually would be the causes? What
steps should I take in identifying the cause, including how I can dig
more information about the error from the system (I've already tried
-verbose 4 and -logverbose 4 and no more information was given on stderr
or in the log file.)?


Basic setup info:


Xserver: 1.7.6-4.fc12

Xorg-x11-drv-intel: 2.9.1-1.fc12


I can post a copy of Xorg.0.log if anyone may find it helpful.







-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.x.org/archives/xorg/attachments/20100811/9cb58c3d/attachment.html>

More information about the xorg mailing list