AllocNewConnection fails:: (fd > lastfdesc)

vrushali shinde vrushali1201 at
Thu Aug 19 05:47:10 PDT 2010

Hello All,

When I run Xfbdev server with IPV4 on a target machine, for initial 3-4 mins
everything is fine and I can launch clients. However, after some  time,
below "thrift" error messages are generated by the system from some other
*"Thrift: Thu Jan .....TServerSocket::listen() IPV6_V6ONLY Protocol not
When I try to run any Xclient after this error occurs, *Xserver fails in
AllocNewConnection::: **fd[259] > lastfddesc[256]*
Also Xserver is not ale to launch any client after this error.
Note: Before the above mentioned "thrift" error messages occur, the *fd
values *are* < 256 *and clients are laucnhed successfully. However, after
the "thrift" error messages occur, *fd value > 256 *and clients cannot be
I am not aware of the complete stack running on the system, hence dont know
if any other module is affecting.

Could anyone please let me know  what could be the issue in getting *fd
value>256* ? And how I can trace/ fix the issue?

Note: I also tried compiling Xserver with IPV6, but I still get the same

Thanks and Regards,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the xorg mailing list