Intel card not detected after upgrade

Ole Tange ole at
Mon Dec 13 13:09:27 PST 2010

On Mon, Dec 13, 2010 at 12:14 PM, Chris Wilson <chris at> wrote:
> On Mon, 13 Dec 2010 00:27:06 +0100, Ole Tange <ole at> wrote:
>> I just upgraded a Debian system.
>> After the upgrade X refuses to use the intel driver but insists on using VESA.
> $ echo options i915 modeset=1 > /etc/modprobe.d/i915-kms.conf
> This should have been taken care of during a debian upgrade.

This was actually taken care of by the upgrade. What was missing was
adding i915 to /etc/modules; when I added that, everything worked as

This is the second time I have be bitten by a missing loaded module
(First time:
It would be terrible helpful if the error message for Xorg mentioned
that you might need to load a module, as Xorg clearly detected my
intel card and thus should be able to guess that I probably wanted to
use the intel driver. If Xorg.0.log had contained a message like:

  "Detected Intel Corporation Mobile 945GM/GMS, 943/940GML Express
Integrated Graphics Controller. Using VESA because kernel module i915
is not loaded."

I would probably have solved this by myself.


More information about the xorg mailing list