thinkpad button/touchpad problem with recent X releases

Peter Hutterer peter.hutterer at
Wed Dec 22 17:01:56 PST 2010

On Thu, 23 Dec 2010 10:20:21 +1100, Dave Davey <daved at> wrote:
> I have a thinkpad R61 with 5 mouse buttons, a touchpad and a red button
> joystick in the middle of the keyboard.  The buttons are arranged like this:
> 1 2 3
>  pad
> 4   5
> I use this machine with openSuSE 11.2 (and 11.1) before that, and the
> buttons and touchpad work as I would expect.  (Button 4 equivalent to button
> 1; 5 eq to 3; 4+5 eq 2).
> With openSuSE 11.3 (and with Fedora 14 and Ubuntu 10.10) I have the following
> problem:
> 	Press and hold any of buttons 1, 2, 3
> 	Move the pointer with the touchpad (even the smallest possible amount)
> 	A buttonrelease event occurs
> This makes many normal operations impossible, e.g. making a choice from an
> xterm menu with Ctrl+button[1|2|3].
> The same buttonrelease does not occur with buttons 4 or 5.  It does not
> happen at all with pointer motion induced with the joystick.
> I also note that touchpad tapping does not simulate button 1 pushing.
> I have compiled and installed the synaptics_drv module from
> xf86-input-synaptics-1.2.0 and it does not change the abovementioned behaviour
> back to that I see with earlier systems.  I have also tried
> xf86-input-synaptics-1.3.0, and see no change.
> What else can I try?

the button release event would be a server bug since the touchpad and
the joystick thingy are two different devices to the server. I just
tried this use-case with current git master and it works fine, so
there may be a bug with server 1.9. Can you try to reproduce with
current git?


More information about the xorg mailing list