modular build, libGL "make install" fails

David Gerard dgerard at
Mon Feb 1 04:38:40 PST 2010

On 31 January 2010 16:31, Dan Nicholson <dbn.lists at> wrote:
> On Sat, Jan 30, 2010 at 3:17 PM, David Gerard <dgerard at> wrote:

>> Is this a bug, or just me? This is doing the modular build with jhbuild:
>> /home/fun/.local/bin/install-check -d /usr/local/include/GL
>> install: cannot change permissions of `/usr/local/include/GL': No such
>> file or directory
>> I'm doing a build in my home directory, but it appears to be trying to
>> do things to the system. Surely that's not right ...

> Mesa is trying to install in /usr/local, apparently. I don't know what
> jhbuild is doing, but obviously we'd need to see more context.

Indeed. I tried again from clean (and using the jhbuildrc that's
actually in git!), but it did it again.

I also tried on FreeBSD 8.0 and it *didn't* do this. This sugggests
there's some weird config stuff going on here - it does appear to be a
build system thing, not a Mesa thing ... will investigate further.

(My goal is to make it easy for people to just build Xorg from git
head casually and anywhere. This way they won't have to wait until
their distro updates to discover that Xorg removed some little thing
they happen to rely on a year ago. Also, more eyes = more bug reports,

- d.

More information about the xorg mailing list