/usr/lib/libSM.so.6: undefined reference to `uuid_unparse_lower'

Dave Henning dave at evlax.com
Fri Feb 5 23:35:16 PST 2010

I am running Ubuntu Desktop 9.10 and am having a problem with the
Session Manager library.  

I am seeing the following error now in two very different instances:

/usr/lib/libSM.so.6: undefined reference to `uuid_unparse_lower'

The first instance is when trying to run the ies4linux packages (i.e.
IE6 under Wine).  

The second is when trying to compile a simple "Hello World" program that
uses wxwidgets with g++.

I have tried re-installing the uuid and libsm6 packages.  I am afraid I
might have broken something when trying to install Wine, but that is
just a guess based on when I first saw the problem.

I ran the following command to see if the uuid_unparse_lower is in my
uuid :

$objdump -T /lib/libuuid.so.1.3.0  | grep uuid_unparse_lower

and the symbol is there.  Here is the output:

00002520 g    DF .text	00000026  UUID_1.0    uuid_unparse_lower

I don't know what else to try.  I have tried googling, but the only
thing that looks relevant is in German (which I don't understand).

Does anyone have any ideas?

Dave ...

More information about the xorg mailing list