strange terminal-emulators-only behaviour: broken key-map?

Marius Gedminas marius at
Fri Jul 9 10:54:25 PDT 2010

On Fri, Jul 09, 2010 at 05:03:53PM +0200, Simone wrote:
> >  strangely it seems that *only* my gnome-terminal/xterm stopped to
> > correctly map my keyboard (pc105). Other applications (gedit,
> > openoffice,...) still work correctly.
> > For example, if I type shift+3, I should get the "£" character but I
> > get "#"+return and "èéàç" keys are no longer working, printing out
> > empty spaces. Same behavior in xterm or other terminals...
> > I also tried the "fr" layout with the same result: "£" is mapped to "#"+return.
> Today I discovered that the behavior is related to the BASH shell
> only. When I I use the SH shell, the terminal's keymap works as
> expected. I cannot figure out why the interaction between BASH and
> x-terminals is broken, any idea?

Check /etc/inputrc or ~/.inputrc for suspicious settings.

Marius Gedminas
We don't care.  We don't have to.  We're the Phone Company.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 198 bytes
Desc: Digital signature
URL: <>

More information about the xorg mailing list