[solved] Re: Various x apps (xterm, xfontsel) don't start due to missing fonts

Shiva Persaud shivapd at yahoo.com
Sun Mar 27 11:22:29 PDT 2011

> I'm having what appears to be a common problem but not of
> the solutions I've found on various forums and threads have
> worked for me.
> I noticed this issue after I configured my system to use
> the en_US.utf8 locale but it's possible that this issue
> existed before that change. Note that in debugging I've gone
> back to using having POSIX as my locale and the problem
> persists.
> I noticed then when I did a ctrl-right click xterm windows
> would close. I
> started an xterm from an xterm and ctrl-right clicked on
> the new xterm and saw the following error message:
> <begin>
> ~(245)$ xterm
> Warning: Cannot convert string
> "-adobe-helvetica-bold-r-normal--*-120-*-*-*-*-iso8859-*"
> to type FontStruct
> Warning: Unable to load any usable ISO8859 font
> Warning: Unable to load any usable ISO8859 font
> Error: Aborting: no font found
> <end>

Turns out my distro make a change such that if font packages are installed and UTF support is not enabled on the system, the ISO 8859-1 fonts were not installed. UTF support was not enabled on my system. Thus, when various x apps went looking for the needed fonts, they wouldn't find them. Details @ http://bugs.gentoo.org/show_bug.cgi?id=359679#c16.

More information about the xorg mailing list