unable open xterm

Thomas Dickey dickey at his.com
Mon May 9 14:07:54 PDT 2011

On Mon, 9 May 2011, Usuário do Sistema wrote:

> disregard my before email! sorry.
> I've just tried:
> 1- export DISPLAY=:0.0
> 2- xauth -f path list
> xauth:  creating new authority file path
> but the same error occur when I run xterm
> Warning: This program is an suid-root program or is being run by the root user.
> The full text of the error or warning message cannot be safely formatted
> in this environment. You may get a more descriptive message by running the
> program as a non-root user or by removing the suid bit on the executable.
> xterm Xt error: Can't open display: %s

If you're logged in as root, then the X libraries (from ~10 years ago)
will ignore the $DISPLAY variable.  It used to be a reliable workaround
to simply use the -display option (but I've seen a few machines where 
that's been broken).  That is

 	xterm -display :0.0

As noted, if you were using ssh -X, then the display would be set 
more/less automatically.

With RHEL 5.6, it's unlikely that xterm itself is setuid, since Red Hat's
been using utempter since RHEL 4.x - but on the odd chance that someone's
"fixed" your machine, stripping the setgid bit (or setuid...) won't do
much more harm than disable utmp updates.

Thomas E. Dickey

More information about the xorg mailing list