X11 forwarding

gene heskett gheskett at wdtv.com
Sat May 28 08:34:59 PDT 2011

On Saturday, May 28, 2011 11:23:13 AM Sérgio Basto did opine:

> On Sat, 2011-05-28 at 10:54 -0400, gene heskett wrote:
> > Greetings;
> > 
> > Where can I find a tut that will show me how to make X11 forwarding
> > work like it used to 2-3 years ago?
> > 
> > The usual "ssh -Y -l gene shop" hasn't worked right in quite a while,
> > basically from the responses I'm seeing about bad UUID's. because gene
> > on this pclos box is UUID 500, and gene on the shop (ubuntu 10.4 LTS)
> > box is UUID 1000.  Whomever decided that UUID's were the cats meow
> > rather then the login name, has made it very very difficult to do
> > what should be a very simple task.
> Hi,
> at: /etc/ssh/sshd_config
> now the default is no, edit and
> put :
> X11Forwarding yes
> and restart sshd

On the ubuntu box, I had apparently BTDT.  It was commented out on this 
pclos box.  Set it & restarted sshd here.

gedit's gui does display ok, but I'm a vim guy, and it complains.

That machines main function is to run emc as its tied to a cnc milling 
machine.  The emc gui will not properly forward if the gui being used is 
axis.  tkemc, which has no backplot function, does run, but that is a very 
simple gui, not as useful as axis.  So maybe this isn't a UUID problem, but 
that is what vim complains about. 


In my attempt to demo it by editing a file with vim, it worked flawlessly.
Me, goes off scratching head.  Damned computers will be the end of me yet.

Thanks Sergio.

Cheers, Gene
"There are four boxes to be used in defense of liberty:
 soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
As a goatherd learns his trade by goat, so a writer learns his trade by 

More information about the xorg mailing list