DVI output > monitor blinking at max res. in X session (VGA - OK, text mode OK)

Eduard Tibet eduard.tibet at gmail.com
Sun Feb 3 04:54:31 PST 2013


I've already post this message to other several X-related forums some
time ago, but unfortunately I didn't get some information from there.
Seems that other people didn't faced such problems. Searching this
list for such problem gives some results but don't seem to be the same
as mine.

Initial state:
I have 1 graphic card (based on ATI Radeon 9200) and 2 monitors (both
EIZO) with Debian 6.0 powered PC (default kernel
Monitors have different resolutions: S1961 (1280x1024) and L985EX
(1600x1200). I use only single monitor each time (the other one even
doesn't connected to signal output). Both are works OK in console
(text) modes at all outputs (so technically they are seems to be OK).
S1961 works OK in all modes at all outputs in X session (DVI, VGA).
But L985EX has very strange problem: it works OK in all modes at VGA
output, but begins to blink when using DVI output. It seems like
monitor probing procedure takes place (i.e.: blank screen 1-2 sec. >
restoring image 2-3 sec. > blank screen again 1-2 sec. > restoring
image 2-3 sec.). Other interesting thing that the frequency of such
behaviour is mostly depends on resolution. At default (max res.)
1600x1200 there are no possible to do anything in X session (blanking
and stable image are approx. 2 sec. each). If I change the resolution
to 1280x1024 X session begin more stable (blanking for 1 sec with
20-30 sec. interval of stable image). If I change the resolution
futher to 1024x768 X session begin most stable at DVI output. I don't
face any blinking at all.

My experiments to solve the issue:
Try 1. First I tried to use other hdd with other non X-based OS and it
seems to be OK at 1600x1200 at DVI so it seems not to be a real
hardware problem.
Try 2. Then I tried to upgrade X.org to most recent version from
debian backports repo (first - was, second - upgraded): xserver-xorg
(7.5.8 > 7.6.8), xserver-xorg-core ( >
xserver-xorg-video-radeon ( > Sorry for the
packages name - they are debian specific, because I don't know how it
called in X repo. But nothing happened.
Try 3. I tried to play with xrandr modes, but no success.
Try 4. I tried to put radeon.disp_priority=2 at kernel boot (as
mentioned at [1], [2], [3]) but got an error message: "[5.433004]
radeon: Unknown parameter `disp_priority'" (initial call string:
[0.000000] Kernel command line: BOOT_IMAGE=/vmlinuz-2.6.32-5-686
root=UUID=4ddfc6de-7006-47ae-b142-7fdf1228beae ro quiet
radeon.disp_priority=2 )

Now I don't know where to digg to solve the issue.

I know that I need to provide the X.org.log and dmesg.out, but I don't
know, if I allowed to send it directly to the list.

[1] https://bugzilla.kernel.org/show_bug.cgi?id=26552
[2] https://bugs.freedesktop.org/show_bug.cgi?id=33657
[3] https://bugs.freedesktop.org/show_bug.cgi?id=48772

regards, Eduard

More information about the xorg mailing list