How to start to use Xfbdev

Woody Wu narkewoody at
Fri Sep 6 03:17:34 PDT 2013

Hi, List

I just setup a Xfbdev server on an embedded system which based on
framebuffer (S3C2416 SoC).  Then I met my first problems in staring
Xfbdev. Hope people here can give me some help.

1. What's the right way to start Xfbdev with touchscreen as input?
My touch screen is integrated into Linux input subsystem and appears as
/dev/input/event0.  I tried many ways to pass arguments to Xfbdev, but
all failed with error messages. My ways are: "-mouse
evdev,,device=/dev/input/event0", and "-mouse
tslib,,device=/dev/input/event0".  Finally, I found one way works but
looks not decent at all, that is: make a symbol link
'/dev/input/touchscreen0' to /dev/input/event0, then pass "-mouse tslib"
to Xfbdev.  From the outputed warning messages, I see that Xfbdev
finally falled back to use a default name "/dev/input/touchscreen0".
Although it works, but I believe this is not the right way to do it.
Googled on the net, but helps on Xfbdev command line is not so much

2. All X applications has no title bar and menu bars.
After started Xfbdev, I can lanuch some X applications, such as xclock
and gtk-demo.  All of these applicion have no title bar and menu bars on
the screen.  Does it mean I have to start a window manager application
previously? But a window manager need another piece of memory, I think
may not needed for my embedded single-gui environment.  Anyway, I did
tried a window manager, matchbox. But this time, after started matchbox,
my applications (xclock, gtk-demo) even cannot show up on the screen.
What's wrong with them?

Thanks in advance.

I can't go back to yesterday - because I was a different person then

More information about the xorg mailing list