built Xephyr from source but it complains about missing XKB, and other things.

Alan Coopersmith alan.coopersmith at oracle.com
Sun Jan 26 09:47:30 PST 2014

On 01/25/14 02:32 PM, ... wrote:
> @ Alan:
> Thanks.  I have been unable to find a comprehensive list of what directories I
> would need to set.  I suspect that these xkb issues are just the first in a
> longer list (for instance, there is a long list of success messages that do not
> appear.  So even making this error go away is not success).

./configure --help will list all the flags.

> I am fine clobbering my repo version.  Could I set the --prefix to overlap the
> repo version?  Or, do you know where I could find a more comprehensive list of
> paths I can and should define at compile time?  Or, do you know anything about
> getting the source from the Ubuntu repo and compiling it with
> --enable-kdrive-evdev and --enable-glx-tls?

Sorry - I don't use Ubuntu and don't know how to compile stuff from their repos,
but I suspect if you figured that out you'd find the right set of flags to
overwrite the version from their packages.

> I tried --with-xkb-bin-directory=/usr/bin/ --with-xkb-path=/var/lib/xkb/ and I
> still get the same XKB error.
> Not sure if the xkb-path is right.
> $ ls /var/lib/xkb/
> README.compiled
> server-02D8252E59564A234380F1E5417646A9DB3B7452.xkm
> server-53628FFEAE787BDF7F5128B07068E2A1D9DEC814.xkm
> server-8AA988DD479FAABEC4FC3CCCF4CC29B4948840B4.xkm
> server-8C3648A5FD728529D869F46730BE1BC287DB231C.xkm
> server-B20D7FC79C7F597315E3E501AEF10E0D866E8E92.xkm

Nope, that's not it - it should be something more like this:

% ls /usr/share/X11/xkb/
compat/       geometry/     README        symbols/
compiled/     keycodes/     rules/        types/

The /var/lib/xkb directory is the one for --with-xkb-output, not --with-xkb-path.

	-Alan Coopersmith-              alan.coopersmith at oracle.com
	 Oracle Solaris Engineering - http://blogs.oracle.com/alanc

More information about the xorg mailing list