New Monitor Weirdnesses or how do I get Xorg to pay attention to my xorg.conf file?

Robert Heller heller at
Thu Dec 3 05:25:06 PST 2015

I recently had to replace the monitor on my desktop machine (running CentOS 
5.11 w/Xen), but I am having trouble getting a *sane* display resolution.

First of all this is an 'older' machine (about 5 years old), with a ASRock 
K10N78 motherboard with integrated video: VGA compatible controller: NVIDIA 
Corporation C77 [GeForce 8200] (rev a2).  I have the stock CentOS 5 Xorg 


XOrg is using the vesa driver, since the NVIDIA GeForce 8200 is not supported 
by the nv driver (xorg-x11-drv-nv-2.1.15-4.el5).  This has been *normally* 
fine by me -- my old monitor was a 17" 4:3 monitor that worked just fine at 
1024x768 resolution.  *I* have no need for 3d acceleration. The NVIDIA 
semi-closed driver is not supported under Xen, so hassling with that is not an 
option (and if that was the *only* solution, I'll just have to return the 
monitor to BestBuy and get something else, probably a more expensive 4:3 
monitor from Amazon).  The new monitor is a NOC model 1970 and it is a 19.5" 
16:9 LED monitor.  It only has a VGA connection -- DVI or HDMI are not 

I have tried to set suitable mode lines in my xorg.conf file, but Xorg seems 
to be ignoring them.  Why is this?  What 'magic' do I need to perform to get 
Xorg to behave?  Right now it is coming up in 1024x768 (which is a 4:3 
resolution).  I want *square* pixels, so I want a 16:9 display resolution.  
How do I make that happen?  The Xorg log file and my xorg.conf file are 
available here:

Robert Heller             -- 978-544-6933
Deepwoods Software        -- Custom Software Services  -- Linux Administration Services
heller at       -- Webhosting Services

More information about the xorg mailing list