Xorg 7.6_1 crashes with ATI Mach64 GR Dell FP 2001 using VGA connector

Felix Miata mrmazda at earthlink.net
Thu Jan 15 20:17:35 PST 2015

xorg at lists.killian.com composed on 2015-01-15 18:40 (UTC-0800):

> I've got an old 1U server running openSUSE 13.2 which comes with Xorg
> 7.6_1. Most of the time it is headless, but I would like to be able to use
> X occasionally. Unfortunately out of the box the X server crashes.

> The Monitor is a Dell 2001 FP, which is natively 1600x1200, but since this
> is over a D-sub connector, I need to use 1024x768 (probably 60Hz, or maybe
> 75Hz).

Why is that so?

My Dell 2000FP, which is natively 1600x1200, made January 2003, does all
supported modes over both D-sub and DVI using various ATI, Intel & Nvidia
gfxchips newer than yours. I don't have any Mach64 cards I could try though.

> This works fine in the OS install and GRUB2, but Xorg just crashes after
> the newly installed system boots. I am looking for suggestions on xorg.conf.d
> entries that will make it work. I have tried a lot of things, including using
> the vesa driver and ati driver,

I dont' know that mach64 was ever supported by the "ati" driver. A mach64
driver is on the mirrors, and almost certainly requires KMS be disabled.

> specifying mode
> lines, refresh rates, resolutions, etc. For example with the vesa driver,
> I usually get "VESA(0): No matching modes". Here I will present what
> happens with Xorg -configure with no Device, Monitor, or Screen
> specifications (i.e. let it figure out everything). As you can see it seg
> faults.

> I would very much appreciate some advice on what will get me 1024x768x60Hz
> refresh without the vesa or ati driver crashing on me.

> # hwinfo --gfx
>   Model: "ATI Mach64 GR"

Is that gfxchip on the motherboard? Does it have an empty PCI or video slot?
Something newer might be easier than making that chip work.

> [  7473.357] Kernel command line:
> BOOT_IMAGE=/boot/vmlinuz-3.16.6-2-desktop
> root=UUID=bb29c2e3-7a82-49ce-a4c8-a84bf4ff3d5a video=1024x768
> resume=/dev/md1 splash=silent quiet showopts vga=0x317

It might help troubleshooting to cut down that cmdline down to only what's
needed and leave the messages on tty1, maybe like so:

root=... showopts noresume splash=0 vga=normal video=1024x768 at 60 nomodeset

With showopts near the front it's easier to tweak on the fly, change vga= or
video= or remove video= or nomodeset.

If the mach64 is already installed, and you've tried with both nomodeset on
cmdline and with no xorg.conf together, try an xorg.conf with no more than
the following in it as a starting point:

Section "Device"
	Identifier	"DefaultDevice"
	Driver		"mach64"

Section "Monitor"
	Identifier	"DefaultMonitor"
#	HorizSync	31 - 80
#	VertRefresh	56 - 76
#	Option		"DDC"	"off"
#	Option		"DPMS"	"off"
#	Option		"DefaultModes"	"on"
#	Option		"PreferredMode" "1024x768"

Section "Screen"
	Identifier	"DefaultScreen"
	Device		"DefaultDevice"
	Monitor		"DefaultMonitor"

Section "Extensions"
        Option		"Composite"	"Disable"

If not good enough, try removing the comments. Modelines with Xorg I've never
ever needed, no matter how old the gfxchip.
"The wise are known for their understanding, and pleasant
words are persuasive." Proverbs 16:21 (New Living Translation)

 Team OS/2 ** Reg. Linux User #211409 ** a11y rocks!

Felix Miata  ***  http://fm.no-ip.com/

More information about the xorg mailing list