resolution detected incorrectly.

Sashan Govender sashang at
Wed Jul 8 17:10:58 PDT 2015

When I run gnome this is the output from xrandr:

Screen 0: minimum 64 x 64, current 1920 x 1080, maximum 32766 x 32766
VGA-0 connected primary 1920x1080+0+0 0mm x 0mm
   1920x1080     60.00*+

When I run i3:

Screen 0: minimum 64 x 64, current 1024 x 768, maximum 32766 x 32766
VGA-0 connected 1024x768+0+0 0mm x 0mm
   1024x768      60.00*+

As a result when running i3 it displays at a low resolution that I'd rather
not use so I stay with gnome because the resolution is better.

I have no xorg.conf. Apparently it's not needed anymore and X
autoconfigures itself.

Anyone know how to fix this (yes I have tried manually adding the 1920x1080
resolution using cvt;xrandr --newmode etc... but it does not work).

Note that I am running arch in virtualbox. All the guest vbox modules are
installed (but I doubt they are the issue because at least one window
manager can use the right resolution).
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the xorg mailing list