xf86-input-keyboard not working

Ingo Br├╝ckl ib at wupperonline.de
Tue Mar 17 06:21:39 PDT 2015


I've set up a LFS (Linux From Scratch) system with X Window - all the latest
sources. To test X I'm using twm and xterm-316. Everything's working great
with just one exception: the keyboard doesn't work at all. It does, of
course, work with the linux console, and the mouse works both with the linux
console and with X.

I'm using xf86-input-keyboard-1.8.0 and xf86-input-mouse-1.9.1 for input (no
evdev).

My problem is: Although I do have some experience I don't have any idea what
the problem could be or how to even track down the issue and I am asking for
help.

Strange things is that the same keyboard works with an older PC (also LFS,
but X v7.4 sources, i.e. xorg-server-1.6.3 and xf86-input-keyboard-1.3.2).

There is one noticeable difference in the log files between the two PCs - the
repetitions of the options with the keyboard identifier and one vs. two
"always reports core events" messages:

old:

  (**) Option "CoreKeyboard"
  (**) IBM 1403: always reports core events
  (**) Option "Protocol" "standard"
  (**) IBM 1403: Protocol: standard
  (**) Option "AutoRepeat" "250 30"
  (**) Option "XkbRules" "base"
  (**) IBM 1403: XkbRules: "base"
  (**) Option "XkbModel" "pc102"
  (**) IBM 1403: XkbModel: "pc102"
  (**) Option "XkbLayout" "de"
  (**) IBM 1403: XkbLayout: "de"
  (**) Option "CustomKeycodes" "off"
  (**) IBM 1403: CustomKeycodes disabled
  (II) XINPUT: Adding extended input device "IBM 1403" (type: KEYBOARD)

new:

  (II) Using input driver 'kbd' for 'IBM 1403'
  (**) Option "CoreKeyboard"
  (**) IBM 1403: always reports core events
  (**) IBM 1403: always reports core events
  (**) Option "Protocol" "standard"
  (**) Option "XkbRules" "base"
  (**) Option "XkbModel" "pc102"
  (**) Option "XkbLayout" "de"
  (II) XINPUT: Adding extended input device "IBM 1403" (type: KEYBOARD, id 6)

Ingo


More information about the xorg mailing list