xf86-input-keyboard not working

Hans de Goede hdegoede at redhat.com
Wed Mar 18 02:05:13 PDT 2015


Hi,

On 18-03-15 03:43, Ingo Br├╝ckl wrote:
> I've got it!
>
> It has nothing to do with xf86-input-keyboard or xorg-server, but with
> startx. It nowadays starts X on the current tty due to an issue in
> systemd-logind (according to bugzilla.redhat.com/show_bug.cgi?id=806491).
> This causes xorg-server to enable keeptty and thus the trouble.
>
>  From my point of view the corresponding patch
> (cgit.freedesktop.org/xorg/app/xinit/commit/startx.cpp?id=44915d6953076849b69
> a017f6fc8234b0f254362) should be considered a bug. To fix it properly, the
> xinit configure ought to have a enable-systemd-logind option with auto
> detection - just like xorg-server.
>
> Please fix it.

I do not believe that adding auto-detection to the xinit configure script is
going to help much here, people may be running a Xorg build with systemd-logind
capabilities without actually using it, so I believe that if there is something
to fix we need a runtime check, not a buildtime one.

Other then that I've not been following this thread. Is there a bug report
somewhere were the problem is spelled out step by step, including a detailed
analysis of why you believe the startx behavior is the cause ?

If not please file such a bug report here:
https://bugs.freedesktop.org/enter_bug.cgi?product=xorg&component=App/xinit

And then mail me back with the bug number and I will take a look.

Regards,

Hans


More information about the xorg mailing list