synaptics click both buttons to get middle?

Jeremy C. Reed reed at
Thu Aug 3 20:31:56 UTC 2017

This is on Ubuntu 16.04 with xserver-xorg-input-synaptics          
1.8.2-1ubuntu3 package (and xserver-xorg 1:7.7+13ubuntu3).

synclient does nothing for me. I can set things and see them with 
xinput (or vice versa). Then I realized that it worked when using 
my Dell device:

    DELL0742:00 06CB:7E92 Touchpad            id=13   [slave  pointer  
    SynPS/2 Synaptics TouchPad                id=17   [slave  pointer  

I turned off my two finger scrolling and sensitive touchpad from 
changing my window focus frequently.

xinput --set-prop "DELL0742:00 06CB:7E92 Touchpad" "Synaptics Tap Action" 0 0 0 0 0 0 0
xinput --set-prop "DELL0742:00 06CB:7E92 Touchpad" "Synaptics Two-Finger Scrolling"  0 0
xinput --set-prop "DELL0742:00 06CB:7E92 Touchpad" "Synaptics Edge Scrolling" 0 0 0

But I also want to click the left button and right button simultaneously 
to emulate my middle button to get my X11 paste to work (and xev never 
shows the button 2). (I have 
used this for maybe 20 years on different X11 systems and want to 
continue to use it.)

I set various "Synaptics Middle Button Timeout" values, but can never 
get any paste to work. (For example in xterm, I highlight text then 
press both at same time. In other clients, pressing both at same time 
acts as if just the right button was clicked showing a right-click menu 
for example.)  I also tried setting the Tap Action for the lower left 
and lower right but I think that is about higher on the touchpad and not 
the buttons at the bottom.

Note that this Dell Inspiron 5000 buttons are part of the same touchpad, 
no separate hardware to the user. Underneath it appears to have switch 
on bottom left and right since it depresses and clicks on bottom but 
never on top. (The depress and click starts at about half way down the 

I wonder if this is the problem:

reed at work2:~/tmp$ xinput --list-props "DELL0742:00 06CB:7E92 Touchpad" | grep Capab
        Synaptics Capabilities (331):   1, 0, 0, 1, 1, 0, 0

See how it shows I have no right button. I definitely do as I use it 
with xterm (ctrl-right click) and in firefox and other apps.

Some logging:

[ 52820.192] (II) synaptics: DELL0742:00 06CB:7E92 Touchpad: device does 
not report pressure, will use touch data.

i[ 52820.192] (--) synaptics: DELL0742:00 06CB:7E92 Touchpad: buttons: 
left double triple

I used xev. Left button is "button 1," and right button is "button 3," 
but middle click almost always shows "button 3," and sometimes "button 
1".  Interestingly if I pressed the touchpad (as far up as it will click 
(starting at about 3/4 inch from bottom up until about 3/4 inch from 
top) it always is "button 1" even on the right side. If I go low enough 
on the right side it will be button 3 again. Note this is not a 
touchpad tap which is disabled, but a physical depression of the 
touchpad until it clicks.

Any hints would be appreciated.

More information about the xorg mailing list