International input in xterm and emacs with Xorg

Troy Korjuslommi tjk at
Mon Feb 13 16:37:38 UTC 2017

Hi Richard,
Have you checked that the versions of xterm and emacs are compiled with
support for i18n input? There might be alternate versions available for
Slackware (also my first linux distro), or try to compile them from
Not running Slackware myself, so I can only guess what's wrong...


On Fri, 2017-02-10 at 14:49 -0500, Richard Lemieux wrote:
> Hi,
> I would need a few pointers to online documents explaining clearly the chain of 
> transformations going from keycodes in Linux, to the X11 codes and then to 
> whatever is used in xterm and Emacs. I have got a lot of partial information but 
> I still can't use that to solve my problem.
> The last time I had XFree86 running as my X11 server - something like four years 
> ago, I had managed to be able to enter European accented character in all parts 
> of Linux including xterm, Emacs and so on.  SCIM also worked fine on the xterm 
> and Emacs with that setup. I could enter Chinese file names if I wished.
> Since I migrated to Xorg, I have never managed to get SCIM to work in a Xterm or 
> in Emacs and worse even just have the compose key work in Emacs.  I have been 
> able to make those work intermittently but the whole capability breaks down the 
> next time I reboot.
> I can't recall all the things I have tried based on examples I got from forums.  
> Of course I tried IBUS but that is not better than SCIM for me.
> I am running Slackware.  This is what I run since I started using Linux in the 
> 90's. From what I read people using other distributions have see international 
> input broken on they own system sometimes.
> I still have a bit of hope though since everything I need to do works fine with 
> Firefox and Thunderbird.  With both Firefox and Thunderbird I can use Compose to 
> enter European characters and SCIM to enter Chinese.  So there must be some way 
> to make it run also on Xterm and Emacs.
> Some days ago I used suggestions from a formum and assigned Super_L to RALT 
> using xkbcomp.  That worked the first time I did it but it no longer works???
> My latest attempt was to add "clear mod4"  in .Xmodmap. That worked once but no 
> longer works???
> I have tried Sakura but that one has problems with my Chinese fonts so using 
> Sakura as a terminal is not an answer.
> I am not a develper as such but I write programs for my research.  So there are 
> a lot of things I understand just very approximately on the 
> Linux/X11/xterm/Emacs interconnections and that mapping between keycodes and the 
> other codings used in X11, xterm and Emacs is something I can't understand I guess.
> Thanks for your attention and any suggestion that would make me like Linux again.
> _______________________________________________
> xorg at X.Org support
> Archives:
> Info:
> Your subscription address: %(user_address)s

More information about the xorg mailing list