Xserver Error loading intel_drv.so undefined symbol:I810InitMC

Ken Moffat zarniwhoop at ntlworld.com
Wed Jul 27 20:49:30 UTC 2022

On Wed, Jul 27, 2022 at 08:47:58PM +0200, Ahsan wrote:
> Hello,

Hi Ahsan,

I doubt I can help directly, but a few comments (so, I'm snipping a
lot of your details)

TLDR: Do you really need the intel driver ?

> I am trying to compile X server as part of Buildroot/BusyBox based custom
> Linux distribution. The final generated image is unable to load intel video
> driver (intel_drv.so module). The exact error I am getting is the following:
> [     6.989] (EE) Failed to load /usr/lib/xorg/modules/drivers/intel_drv.so:
> /usr/lib/xorg/modules/drivers/intel_drv.so: undefined symbol: I810InitMC
> [     6.989] (EE) Failed to load module "intel" (loader failed, 0)
> I tried compiling both xserver version 1.20.14 and 21.1.2 but no luck and
> hit the same error twice. I tried two different Intel video drivers with the
> following commit hashes:
> older: 5ca3ac1a90af177eb111a965e9b4dd8a27cc58fc
> newer: 31486f40f8e8f8923ca0799aea84b58799754564
> The cross compilation library used is Glibc
> 	--disable-xvmc \
> 	--enable-sna \
> 	--disable-xaa \
> 	--disable-dga \
> 	--disable-async-swap

For your undefined symbol, google found
with no linked follow-up about how he solved it, but perhaps an
updated version of the intel driver fixed it.

On beyond-linuxfromscratch we've been using an intel git pull from
20210222 with xorg-server-21.1.3 in our last release (11.1).  For
that we configured the intel driver with --enable-kms-only and also
with --enable-uxa .

In our 11.0 release we used the 1.20.13 server with that same
version of the intel driver.  If you are not familiar with BLFS, our
releases list what we think works at that point.  Obviously, people
who care about security are expected to update certain things
afterwards (e.g. xserver if running as root).

The other thing about the intel driver is that most distros use the
modesetting driver which is now part of the xserver (provided you
supply the necessary dependencies).  On my own old haswell with its
integrated graphics I don't build the intel driver and modesetting
works well.

I recall that someone had issues in the past (maybe in late 2019)
with modesetting on skylake, and I see that on my own skylake i3 I
do build the intel driver because of that.  I cannot confirm or deny
that I _need_ that driver, the machine was used as a home server in
2019 and it's such a slow dog to build on that I've no incentive to
see if it needs this (and slower now, of course, with retbleed).  My
last builds there were the versions mentioned above for our 11.1
release and they seem to work ok.

Meanwhile, our development version of BLFS is currently using the
21.1.4 server with that same intel driver, but I have no idea if
anyone has actually built that combination.

 It is very easy to get ridiculously confused about the tenses of
 time travel, but most things can be resolved by a sufficiently
 large ego.        -- The Last Continent

More information about the xorg mailing list