Xserver Error loading intel_drv.so undefined symbol:I810InitMC

Ahsan ahsan at vivaldi.net
Fri Jul 29 11:10:33 UTC 2022

Hi Ken,

Thanks for your input. Please see my comments inline below.

> Date: Wed, 27 Jul 2022 21:49:30 +0100
> From: Ken Moffat <zarniwhoop at ntlworld.com>
> To: xorg at lists.x.org
> Subject: Re: Xserver Error loading intel_drv.so undefined
> 	symbol:I810InitMC
> Message-ID: <YuGk2inKZGc/w484 at llamedos.localdomain>
> Content-Type: text/plain; charset=utf-8
> On Wed, Jul 27, 2022 at 08:47:58PM +0200, Ahsan wrote:
>> Hello,
> Hi Ahsan,
> I doubt I can help directly, but a few comments (so, I'm snipping a
> lot of your details)
> TLDR: Do you really need the intel driver ?

No, there is no hard requirement for this, unfortunately, this error 
loading the intel driver module properly hence a target machine ends up 
incorrect resolution. The idea is to avoid this error so that loading of
intel module (for Intel HD 630) works fine.
In a previous version of BR, the combination of intel drivers and xorg 
works fine, however, in a new BR release, the combination is broken and
I end up with the error above. So far, I've found that the intel video
driver version is same for both xorg 1.20.xx and 1.21.2 (or 21.1.2).
I'm not sure if something changed in 21.1.x that causes i810InitMC
error or it's the intel driver.

> For your undefined symbol, google found
> https://www.openwall.com/lists/sabotage/2015/01/07/1
> with no linked follow-up about how he solved it, but perhaps an
> updated version of the intel driver fixed it.
> On beyond-linuxfromscratch we've been using an intel git pull from
> 20210222 with xorg-server-21.1.3 in our last release (11.1).  For
> that we configured the intel driver with --enable-kms-only and also
> with --enable-uxa .

I tried --enable-kms-only(the other flag is already enabled) but no 
Are we talking about the following repo?
$ git remote -v

If so, the last commit seems to be on 2021-01-15(few commits pasted 
Am I missing something here or may be I'm confusing something?

* 31486f40 2021-01-15 | sna: Always validate userptr upon creation (HEAD 
-> master, origin/master, origin/HEAD) [Chris Wilson]
* ab906aa0 2021-01-10 | sna/gen7: Avoid clear-residuals overhead on all 
gen7 [Chris Wilson]
* a511f22c 2020-12-15 | sna: Enable TearFree by default on recent HW 
[Chris Wilson]
* 9236c582 2020-11-26 | sna: Defer fbGetWindowPixmap() for sna_composite 
[Chris Wilson]
* ad5540f6 2020-11-16 | More ABI changes for ABI_VIDEODRV_VERSION 25.2 
[Chris Wilson]
* 4e8ae05f 2020-11-16 | Track ABI changes for ABI_VIDEODRV_VERSION 25.2 
[Chris Wilson]
* 67f15b36 2020-08-20 | sna/gen7: Prefer blitter for plain copies on 
Haswell [Chris Wilson]
* 5ca3ac1a 2019-10-28 | sna/video/overlay: Declare support for depth 8 
and 30 [Ville Syrjälä]

> In our 11.0 release we used the 1.20.13 server with that same
> version of the intel driver.  If you are not familiar with BLFS, our
> releases list what we think works at that point.  Obviously, people
> who care about security are expected to update certain things
> afterwards (e.g. xserver if running as root).
> The other thing about the intel driver is that most distros use the
> modesetting driver which is now part of the xserver (provided you
> supply the necessary dependencies).  On my own old haswell with its
> integrated graphics I don't build the intel driver and modesetting
> works well.>

I think, I came across LFS and found some information regarding intel
video driver useful.
In my case, modesetting don't guess the resolution correctly, and intel
driver does the job.
At this point, I am trying to figure out how can I disable the legacy
support during intel video driver compilation. If there's any pointer
on that, I'll appreciate.

> I recall that someone had issues in the past (maybe in late 2019)
> with modesetting on skylake, and I see that on my own skylake i3 I
> do build the intel driver because of that.  I cannot confirm or deny
> that I _need_ that driver, the machine was used as a home server in
> 2019 and it's such a slow dog to build on that I've no incentive to
> see if it needs this (and slower now, of course, with retbleed).  My
> last builds there were the versions mentioned above for our 11.1
> release and they seem to work ok.
> Meanwhile, our development version of BLFS is currently using the
> 21.1.4 server with that same intel driver, but I have no idea if
> anyone has actually built that combination.
> ?en
> --
>  It is very easy to get ridiculously confused about the tenses of
>  time travel, but most things can be resolved by a sufficiently
>  large ego.        -- The Last Continent


More information about the xorg mailing list